Поиск файлов и папок
Вы можете искать файлы и папки по различным критериям: имени, размеру, дате и времени, атрибутам и содержащемуся тексту. После поиска с найденными файлами и папками можно работать: просматривать, редактировать, копировать, перемещать, удалять и т. д.
Чтобы найти файлы и папки:
- Откройте на панели папку, с которой нужно начать поиск.
- Откройте окно поиска:
Меню: Команды/Поиск файлов и папок... Сочетание клавиш: Alt+F7 или Ctrl+F Панель инструментов: Нажмите кнопку «Поиск файлов и папок» на верхней, центральной или нижней панели инструментов. - В поле «Имя» введите имя искомого файла или папки. Для поиска группы файлов или папок со сходными именами либо расширениями используйте маски файлов. Важно: если маска не содержит звездочки (*), вопросительного знака (?) или точки (.), Sally находит все файлы и папки, имена которых содержат эту маску (например, маска "dog" найдет "dogs.txt", "hotdog.jpg" и т. п.). Чтобы избежать этого, добавьте точку (.) в конец маски (например, "dog." найдет только "dog").
- В поле «Область поиска» укажите папки, с которых нужно начать поиск. По умолчанию здесь указана текущая папка панели. Кнопка «Добавить» позволяет выбрать другую папку и добавить ее в поле «Область поиска» либо добавить все локальные или сетевые диски.
- Установите флажок «Искать во вложенных папках», если нужно также искать во вложенных папках каталогов, указанных в поле «Область поиска».
- Для поиска файлов, содержащих определенный текст, установите флажок «Искать в содержимом файлов» и задайте искомый текст в поле «Содержит». Подробнее о параметрах поиска см. в разделе окна поиска.
- Для задания дополнительных условий по размеру файла, атрибутам, дате и времени нажмите «Дополнительно», чтобы открыть окно «Дополнительные параметры».
- Некоторые папки можно игнорировать (исключить из поиска), например System Volume Information в корнях дисков или папки временных файлов. Укажите их в окне «Пропускаемые папки». Оно открывается пунктом «Параметры/Пропускаемые папки» в окне поиска (Ctrl+G).
- Все ошибки, возникающие при поиске, и все пропущенные папки добавляются в окно журнала поиска. Выберите пункт «Открыть журнал по завершении поиска» в меню «Параметры», чтобы видеть журнал по окончании поиска при наличии ошибок. Для открытия журнала вручную используйте команду «Журнал поиска» (Ctrl+L) в меню «Команды» или кнопку журнала справа от заголовка списка найденных объектов.
- Нажмите кнопку «Найти», чтобы начать поиск.
Примечания
Sally показывает ход поиска. Вы можете продолжать работать с Sally, пока поиск идет в фоновом режиме. Можно открыть еще одно окно поиска и одновременно начать новый поиск.
Найденные файлы и папки отображаются в списке найденных объектов. Щелкните заголовок столбца, чтобы отсортировать список по имени, размеру, пути или времени. Также доступны команды сортировки в меню «Вид».
После поиска с найденными файлами и папками можно работать. Перейдите в список найденных объектов и используйте команды меню «Файлы»:
- «Открыть» (клавиша Enter): открывает файл или папку в фокусе,
- «Открыть все выделенные» (клавиша Shift+Enter): открывает все выделенные файлы и папки,
- «Перейти» (клавиша Space): устанавливает фокус на соответствующем файле или папке на активной панели (и переключает на эту панель),
- «Скрыть» (клавиша Ctrl+H): скрывает выделенные файлы или папки из списка найденных объектов,
- «Скрыть дублирующиеся имена» (клавиша Ctrl+Shift+H): некоторые элементы могут быть найдены несколько раз (см. ниже команду «Добавить к найденному»); скрывает повторяющиеся элементы из списка найденных объектов,
- «Просмотр» (клавиша F3), «Просмотр с помощью» (клавиша Ctrl+Shift+F3), «Альтернативное средство просмотра» (клавиша Alt+F3): просматривают файл в фокусе,
- «Правка» (клавиша F4) и «Правка с помощью» (клавиша Ctrl+Shift+F4): редактируют файл в фокусе,
- «Удалить» (клавиша F8 или Delete): удаляет выделенные файлы и папки (помещает их в корзину),
- «Меню пользователя» (клавиша F9): открывает меню пользователя для выделенных файлов и папок,
- «Свойства» (клавиша Alt+Enter): открывает окно свойств выделенных файлов и папок.
С помощью перетаскивания можно скопировать или переместить найденные файлы и папки из списка найденных объектов в любое место. Другой вариант — буфер обмена: найденные файлы и папки из списка найденных объектов можно вырезать или скопировать в буфер обмена (см. меню «Правка»), а позже вставить в нужное место.
Если нужно скопировать имя найденного файла или папки, используйте одну из следующих команд меню «Правка»:
- «Копировать путь и имя в буфер» (клавиша Alt+Insert): копирует полный путь к файлу или папке в фокусе в буфер обмена,
- «Копировать имя в буфер» (клавиша Alt+Shift+Insert): копирует имя файла или папки в фокусе в буфер обмена,
- «Копировать текст в буфер» (клавиша Ctrl+Alt+Insert): копирует путь к файлу или папке в фокусе в буфер обмена,
- «Копировать UNC-путь и имя в буфер» (клавиша Ctrl+Shift+Insert): копирует UNC-путь к файлу или папке в фокусе в буфер обмена.
В некоторых случаях полезно искать среди уже найденных файлов (значения полей «Имя» и «Область поиска» игнорируются). Команда «Поиск в найденном» (клавиша Ctrl+I) в меню «Команды» или раскрывающемся меню кнопки «Найти» оставляет только найденные файлы и папки, соответствующие условиям окна поиска. Например, сначала можно найти все файлы со словом "car" (командой «Найти»), а затем оставить среди них файлы со словом "John" (командой «Поиск в найденном»), получив файлы с обоими словами. Аналогично команда «Удалить из найденного» (клавиша Ctrl+S) скрывает найденные файлы и папки, соответствующие условиям окна поиска. В предыдущем примере результатом будут все файлы, содержащие "car", но не содержащие "John".
Еще одна специальная команда — «Добавить к найденному» (клавиша Ctrl+W) в меню «Команды» или раскрывающемся меню кнопки «Найти». В отличие от команды «Найти», она не очищает список найденных объектов перед поиском, позволяя легко объединять результаты. Один файл или папка могут появиться несколько раз. Командой «Скрыть дублирующиеся имена» можно удалить такие повторяющиеся элементы.
В окне поиска можно найти дубликаты файлов. Подробнее см. в разделе «Поиск дубликатов файлов».
Текущие настройки окна поиска можно сохранить командой «Сохранить текущий профиль» (Ctrl+N) в меню «Параметры». Она открывает окно «Профили поиска». В следующий раз эти настройки можно применить, выбрав их имя в меню «Параметры». Для просмотра или удаления настроек используйте команду «Управление профилями» (Ctrl+M) в меню «Параметры».
См. также
Окно поиска
Окно «Дополнительные параметры»
Окно «Пропускаемые папки»
Окно журнала поиска
Поиск дубликатов файлов
Окно «Профили поиска»
Ограничения групповой политики
From the Sally manual (GPL-2.0-or-later), © 1997-2023 Open Salamander Authors; © 2025-2026 Elias Bachaalany. Source: manual source (zip) · original page in the Sally repository