查找文件和目录
您可以按名称、大小、日期和时间、属性、包含的文本等多种条件搜索文件和目录。搜索完成后,可以对找到的文件和目录进行查看、编辑、复制、移动、删除等操作。
搜索文件和目录:
- 在面板中打开要开始搜索的目录。
- 打开查找对话框:
菜单: 命令(C)/查找文件和目录(F)... 快捷键: Alt+F7 或 Ctrl+F 工具栏: 选择顶部、中间或底部工具栏上的查找文件和目录按钮。 - 在命名的框中,输入要查找的文件名或目录名。使用文件掩码可搜索名称或扩展名相似的一组文件或目录。重要提示:如果指定的掩码不含星号 (*)、问号 (?) 或点 (.),Sally 会查找名称包含该掩码的所有文件和目录(例如,指定“dog”会找到“dogs.txt”、“hotdog.jpg”等)。在掩码末尾添加点 (.) 可避免这种情况(例如,指定“dog.”只会找到“dog”)。
- 在查找位置框中指定搜索的起始目录。此框默认填写面板中的当前目录。使用添加按钮可以浏览其他目录并将其添加到查找位置框,也可以将所有本地或网络驱动器添加到此框。
- 选中搜索子目录框,还可搜索查找位置框所指定目录的子目录。
- 如果要搜索包含某些文本的文件,请选中搜索文件内容框,并在包含字段中指定要搜索的文本。有关搜索选项的详情,参见查找对话框。
- 如果还需要指定文件大小、属性或日期和时间条件,请单击高级按钮,打开高级选项对话框。
- 您可能需要忽略某些目录(将其排除在搜索之外),例如根目录下的 System Volume Information 或存放临时文件的目录。在忽略目录列表对话框中指定这些目录。通过查找对话框中的选项/忽略目录列表菜单项 (Ctrl+G) 可打开它。
- 搜索过程中发生的所有错误及所有被忽略的目录都会记录到查找日志对话框中。如果希望搜索结束且发生错误时显示日志,请选中选项菜单中的“查找后显示错误消息”。要手动显示日志,可使用命令菜单中的显示查找日志命令 (Ctrl+L),或找到的项目列表标题右侧的查找日志按钮。
- 选择立即查找按钮开始搜索。
备注
Sally 会显示搜索进度。搜索在后台进行时,您可以继续使用 Sally。也可以打开另一个查找对话框,同时开始新的搜索。
找到的文件和目录显示在找到的项目列表中。单击列标题可按名称、大小、路径或时间排序,也可使用查看菜单中的排序命令。
找到文件和目录后,即可对其进行操作。转到找到的项目列表,使用文件菜单中的命令:
- 打开(Enter 键):打开焦点所在的文件或目录;
- 打开所有选中项(Shift+Enter 键):打开所有选中的文件和目录;
- 焦点(Space 键):在活动面板中定位焦点所在的文件或目录(并切换到该面板);
- 隐藏(Ctrl+H 键):从找到的项目列表中隐藏选中的文件或目录;
- 隐藏重复名称(Ctrl+Shift+H 键):某些项目可能被多次找到(参见下文的追加到找到的项目命令),此命令从找到的项目列表中隐藏多余的项目;
- 查看(F3 键)、查看方式(Ctrl+Shift+F3 键)、备用查看(Alt+F3 键):查看焦点所在的文件;
- 编辑(F4 键)和编辑方式(Ctrl+Shift+F4 键):编辑焦点所在的文件;
- 删除(F8 或 Delete 键):删除选中的文件和目录(放入回收站);
- 用户菜单(F9 键):为选中的文件和目录打开用户菜单;
- 属性(Alt+Enter 键):为选中的文件和目录打开属性对话框。
您可以通过拖放,将找到的项目列表中的文件和目录复制或移动到任意目标位置。也可以使用剪贴板:将找到的项目列表中的文件和目录剪切或复制(参见编辑菜单)到剪贴板,稍后再粘贴到所需位置。
如果需要复制找到的文件名或目录名,请使用编辑菜单中的以下命令之一:
- 复制 路径 + 名称 为文本(Alt+Insert 键):将焦点所在文件或目录的完整路径复制到剪贴板;
- 复制名称为文本(Alt+Shift+Insert 键):将焦点所在的文件名或目录名复制到剪贴板;
- 复制路径为文本(Ctrl+Alt+Insert 键):将焦点所在文件或目录的路径复制到剪贴板;
- 复制 UNC路径 + 名称 为文本(Ctrl+Shift+Insert 键):将焦点所在文件或目录的 UNC 路径复制到剪贴板。
在某些特殊情况下,在已经找到的文件中继续搜索会很有用(此时忽略命名的和查找位置框中的值)。使用命令菜单或立即查找按钮下拉菜单中的“精练 - 和焦点项目交叉”(Ctrl+I 键)命令,可仅保留符合查找对话框所指定条件的文件和目录。例如,先查找所有包含单词“car”的文件(使用立即查找命令),再筛选这些文件,仅保留包含单词“John”的文件(使用“精练 - 和焦点项目交叉”命令),便得到同时包含这两个单词的所有文件。同样,使用“精练 - 从找到项目中减去”(Ctrl+S 键)命令,可以隐藏符合查找对话框所指定条件的文件和目录。在前面的例子中,结果将是包含“car”但不包含“John”的所有文件。
另一个特殊命令是命令菜单或立即查找按钮下拉菜单中的“追加到找到的项目”(Ctrl+W 键)。与立即查找不同,此命令不会在搜索前清空找到的项目列表,便于合并搜索结果。同一文件或目录可能出现多次,使用隐藏重复名称命令可移除这些多余的项目。
您可以在查找对话框中查找重复文件。详情参见查找重复文件。
使用选项菜单中的添加当前 (Ctrl+N) 命令,可以保存查找对话框的当前设置。该命令会打开设置管理器对话框。下次在选项菜单中选择该设置名称即可使用。要查看或删除这些设置,请使用选项菜单中的管理 (Ctrl+M) 命令。
另请参阅
查找对话框
高级选项对话框
忽略目录列表对话框
查找日志对话框
查找重复文件
设置管理器对话框
组策略限制
From the Sally manual (GPL-2.0-or-later), © 1997-2023 Open Salamander Authors; © 2025-2026 Elias Bachaalany. Source: manual source (zip) · original page in the Sally repository